CylancePROTECT now compatible with macOS 10.14 Mojave

Back in September, just days before the release of macOS 10.14 Mojave, we recommended users to not update due to a serious compatibility issue with our CylancePROTECT anti-virus software that would cause the computer to deadlock upon reboot. We are happy to announce that with CylancePROTECT version 2.0.1494.546 and higher, the issue has been resolved. Continue reading CylancePROTECT now compatible with macOS 10.14 Mojave

Mac Users: Don’t Upgrade to Mojave… Just Yet!

The newest version of macOS 10.14 Mojave is expected to be released Monday, September 24, 2018. We highly recommend not updating to this OS as it will be problematic for various software packages causing software to not run and in some cases even lockup your OS. Continue reading Mac Users: Don’t Upgrade to Mojave… Just Yet!