Box to end support for older tools with TLS 1.0

BoxAs Box works to improve their user experience, that sometimes means removing older functionality to make room for new features. In order to maintain the highest security standards, promote the safety of our data, and align with industry-wide best practices, Box will disable the use of Transport Layer Security (TLS) 1.0 across all Box services on June 25, 2018. After this date, TLS 1.1 or higher (TLS 1.1+) must be used. This means if you are using an older web browser, Box application, or 3rd party applications that do not support TLS 1.1+, you will not be able to access Box.

What is TLS?

TLS stands for “Transport Layer Security” and is the protocol to provide privacy and data integrity between two applications. As the most widely deployed security protocol used today, it is used for web browsers and other applications that require data to be securely exchanged over a network. It basically ensures that your connection to a remote endpoint is the one intended through the use of encryption and endpoint identity verification.

Box web and API connections, along with applications such as Box Sync and 3rd party apps, use TLS as a key component of their security.

How do I update?

To avoid any service disruption with this depreciation in Box, please take the following steps:

For Box Applications, use the latest versions of Box Tools, Box Sync, Box Sync Long Term Installer, Box for Office, and Box Drive. You will need to upgrade prior to June 25, 2018, to continue to access Box.

The minimum versions of Box Apps that comply with TLS 1.1+ are as follows:

Box Product Minimum Compliant Version Download Latest Version
Box Tools Available now!
Mac & Windows: 3.5+
Find system requirements and download links here.
Box Sync Long-term installer – 4.0.7901
Mac & Windows: 4.0.7900+
Find system requirements and download links here.
Box Drive Available now!
Mac: 1.7+
Windows: All Versions
Download here.
Box for Office Available now!
Windows: 4.2.1220+
Download here.

TLS 1.1+ Compliant Browsers

To ensure that you are TLS 1.1+ compliant, make sure your browsers are updated to these minimum versions below prior to June 25, 2018, to continue to access Box:

Browser TLS 1.1 TLS 1.2
Chrome 22-25+ 30-32+
Safari 7+ 7+
Firefox 27–33+

ESR 31.0–31.2+

27–33+

ESR 31.0–31.2+

Internet Explorer 11+ 11+
Edge All Versions All Versions

If you have any problems or concerns about this change, please feel free to contact the IT Help Desk at 214.768.HELP (4357).

Published by

Ian Aberle

Ian Aberle is the IT Communications Specialist and Trainer for the Office of Information Technology (OIT) at Southern Methodist University (SMU). He started at SMU in 1996 and for much of his career at the University had managed the SMU STAR Program before joining the Training & Communications Team in 2015. In his free time, Ian enjoys photography and road trips with his family. You can see examples of when the two collide at http://ianaberle.com.